I have an Asus M3A79-T Deluxe motherboard on which I’m using RAID 5. Sounds simple enough, right?  Well, it ain’t.

The fucker breaks RAID almost as soon as I fix it.  The first time it happened, I didn’t think much of it because I rarely restart my computer, because I couldn’t see a non-functioning drive in Windows and because I wasn’t getting any other sorts of errors, so it was no big deal. Eventually, I changed my mind and tried to fix it.  Eventually, I fixed it.  Shortly, it was broken again.  Both times, it’s drive2 that’s “critical” and the BIOS-based editor is totally friggin’ useless.

So this morning, since the Eagles aren’t on till later, I decided to fix it again.  I’d done it once, right?  The problem is that I have no idea now how I fixed it then.  I remember pain.  So I search and I search.  There’s some Intel program (doesn’t work with AMD Phenom chips – fuck), there’s some nVidia program (doesn’t work with anything but low-level integrated nVidia chipsets – what?  And who trusts a video card company with their disk management anyway?), and then I found RAIDXpert.  That’s a download link, in case you care – it was a pain in the ass to find.  RAIDXpert is some browser based thing that seems to be working on my array right now as I type.  I just logged in (logged in? You’ll need admin/admin as the username and password to log into the browser-based program that points to Localhost, FYI), mucked around, and eventually started rebuilding the array.  it’s at 15%.

I’m going to go away and come back, just to see what happens.  I have a laptop with Ubuntu to fix anyway.

It seemed to have worked, so I’ll restart and then update to let you know.

And it seems to have worked. The BIOS is reporting a RAID5 array in perfect working order and there were no issues with windows or my data.  So it’s RAIDXpert FTW.